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Schlumberger is the leading oilfield services provider, trusted to deliver superior results and 
improved E&P performance for oil and gas companies around the world. Through our well 
site operations and in our research and engineering facilities, we develop products, services, 
and solutions that optimize customer performance in a safe and environmentally sound 
manner. 

 

Documentation is provided in the following electronic formats via the listed location: 

 Techlog 2017 Installation and Licensing Guide (Adobe® Acrobat® PDF file) 

 Online help: Techlog Help > User guide menu 

You can use Adobe® Reader to read the PDF file. Adobe Reader installation programs for 
common operating systems are available for a free download from the Adobe Web site at 
www.adobe.com. 

 

The following conventions are observed throughout this guide: 

 Bold text is used to designate file and folder names, dialog titles, names of buttons, 

icons, and menus, and terms that are objects of a user selection. 

 Italic text is used for word emphasis, defined terms, and manual titles. 

 Monospace text (Courier) is used to show literal text as you would enter it, or as it 

would appear onscreen. 
 

The alerting statements are Notes, Cautions, and Warnings. These statements are formatted 
in the following style: 

 Note: Information that is incidental to the main text flow or to an important point or tip 

provided in addition to the previous statement or instruction. 

 Caution: Advises of machine or data error that could occur should the user fail to take or 

avoid a specified action. 

 Warning: Requires immediate action by the user to prevent actual loss of data or where 

an action is irreversible, or when physical damage to the machine or devices is possible. 

  

http://www.adobe.com/
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Schlumberger has sales and support offices around the world. For information on contacting 
Schlumberger, please refer to the information below. 

 

Technical Support for SIS software Technical Support Website  

Internet www.slb.com  

 

http://support.software.slb.com/Pages/Overview.aspx
http://www.slb.com/
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This guide explains how to install Techlog.  

The guide also explains the procedures required after the installation: 

 Defining your license environment 

 Using license borrowing 

 Requesting the MAC address license to be upgraded to Codemeter Dongle license 

 

This guide explains how to use the Techlog Upgrade Tool. More information is available in 

the dedicated Upgrade tool document when opening the online help from Upgrade tool 

interface. This guide also explains how to configure Studio connection. 
 

This guide is for the users installing Techlog on their workstation. 
 

 

The Support Portal distributes Techlog. 

Techlog is supported on 64-bit architectures. You can install this version on the following 
types of workstations: 

 Microsoft® Windows 10 

 Microsoft® Windows 7® SP1 Enterprise/Ultimate 

 Microsoft® Windows Server® 2012 R2 (64-bit) 

 Microsoft® Windows Server® 2016 (64-bit) 
 

Note: Techlog 2017 does not support Microsoft Windows 8.  
 

Techlog 2017 requires the new 2017 version of Schlumberger Licensing Tool. The old server 
will not work with the 2017 software releases and the license server should be upgraded to 
avoid unnecessary downtime. Schlumberger License Server 2017 is compatible with all 
supported Techlog versions (2014, 2015, 2016, and 2017). 

 

 

To run Techlog, you need a valid license for this release. The license can be configured 
either locally on your computer or on a central license server.  

Techlog uses FlexNet Publisher® licensing to provide a secure licensing solution. Once 
Techlog is successfully installed on your computer, you must install the license to define the 
amount of accessible modules. Refer to the Licensing Techlog section for more information. 

http://support.software.slb.com/Pages/Overview.aspx
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Techlog has minimum system requirements for installation and use. Before installing the product, ensure that your system meets 
the requirements described in this section. 

 Running the Techlog software with the Minimum Supported configuration is not recommended. 

 When working with data containing arrays and images, use the Recommended configuration 

 We recommend that you activate Windows Virtual memory paging default. This enables the system to use the hard disk 

to store information usually stored in RAM. To modify this option: go to Windows control panel > System and Security 

> System > Advanced system settings > Click Settings in the Performance field > Click the Advanced tab > Click 

Change in the Virtual memory field to change the settings. 

 We recommend that you exclude Techlog project storage folder from anti-virus default scan. 
 

 

Operating System Windows 7 64-bit 

Processor Multi-core processor (best with a fast clock speed and high cache)  

Memory 8 GB 

Display Single display 1280 x 1024 pixels 

Graphics NVIDIA Quadro® mid-range card with drivers version : 385.69 

Network 1 Gbps 

Disk storage Hard-Disk Drive (HDD) 
 

 

Operating System Windows 7 64-bit 

Processor Quad-core processor (best with a fast clock speed and high cache) 

Memory 16 GB  

Display Dual display with 1920 x 1200 pixels  

Graphics NVIDIA Quadro® mid-range card with drivers version : 385.69 

Network 1 Gbps 

Disk storage Solid State Drive (SSD) 
 

Note: To run Techlog efficiently, Schlumberger recommends at least 16GB of RAM. The total system 
memory must be greater than the memory used by the application. This ensures that your operating 
system has dedicated RAM so that you do not have to use your page file (disk memory). For 
advanced graphical 3D display and image processing Schlumberger recommends at least 32GB of 
RAM. 

 

Warning: Techlog requires the SMB 2.0 (or newer) protocol to work on networks. 
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Printer Name 

HP DesignJet (1055 CM) 

EPSON Stylus pro 

Printrex 

Iterra 

Standard A4, Letter printers (HP, CLJ 3700/4730 ...). 
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To install Techlog, you need the installation package. If you have a DVD, you can use it. 
Otherwise, download Techlog from the Support Portal. 

 
 

1. Insert the DVD or navigate to the location where you downloaded the installation files. 
2. Unzip the installation package to install the folder tree and click Install Techlog. Or in 

the DVD browser, from the root folder, click Install products and then click Install 
Techlog.  
The InstallShield Wizard message appears while the Techlog installer is extracted. 
When it is finished, the Installer Language panel opens. 

3. Select a language and click OK.  
4. On the Welcome panel, click Next. 
5. On the License agreement panel, read the agreement, click I agree, and click Next. 
6. On the Choose Install Location panel, choose the folder where you want to install 

Techlog, and then click Next. 
7. Click Install. 
8. When the installation is finished, click Finish. 

 

The procedure for the silent mode installation is as follows. This command installs 
Techlog in C:\TechlogFolder. 

1. Open the command prompt (type cmd in Windows search bar). 
2. Type the following command: Install Techlog.exe /Silent 

/InstallFolder=C:\TechlogFolder  
The parameter /Silent is used for the silent mode. The parameter /InstallFolder is used for 

the file location. 
 

  

http://support.software.slb.com/Pages/Overview.aspx
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You can uninstall Techlog from the Start menu or the Control Panel. 

 

Click the Start button > All Programs > Schlumberger > Techlog XXXX.x > Uninstall 
Techlog XXXX.x. 

 

1. Click the Start button > Control Panel > Programs > Uninstall a program. 
2. In the list of currently installed programs, click Techlog, and then click Uninstall. 

 

Define the Company folder according to the organization to share and provide standard 
companies Techlog objects as scripts, templates, families. 

 
To prevent unauthorized modifications, access should be controled on the Company 
Folder Directory.  Edit privileges should be restricted to Company Folder Administrators 
only.  All other authorized users should only have at most read privileges, and non-
authorized users should have all privileges denied.   

 
 

 
To ensure that files containing sensitive data are only accessible to the appropriate 
users, it is important that you review Techlog Folders (Company, Project, Template, 
User, and Temporary) permissions with IT administrator when configuring the file system 
that Techlog will use to store information. 
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Prior to using a network file share for Techlog folders and files, the following settings 
should be reviewed with your IT Administrator: 

 SMB 2.0 or equivalent is required to ensure files can be saved properly 

 Optionally enable SMB Signing to improve security of network communication  

 Optionally enable SMB 3.0 Encryption.  SMB 3.0 is only available with Windows 
Server 2012 and Windows 8+ and encryption should only be enabled if both the 
server and clients have support 

 

After you installed Techlog, you must install the licenses and define which modules are 
accessible.  

 

 

1. Go to the Support Portal. 
2. Log in to the site. 
3. Click Support Resources > Software Download. 
4. On the Welcome Message page, click Continue. 
5. In the Product Group Name list (in the upper-left corner), click Utilities and in the 

Product List, click FLEXlm. 
6. In the table of FLEXlm downloads, click the Download icon for the Schlumberger 

Licensing tool file you need. 

 

1. From the downloaded files, run SchlumbergerLicensing201X.exe. 
The installation wizard opens. 

2. On the Welcome panel, click Next. 
3. Complete the following steps in the Destination Folder panel: 

a. If you want to change the location of the program files, click Change and then 
navigate to a new location. If you are installing on a central license server, select a 
folder on the central license server. 

b. Click Next. 

4. On the Ready to install panel, click Install. 
5. When the installation is complete, on the last panel select Launch Schlumberger 

Licensing and then click Finish. 
You are ready to configure the Techlog license. 

If you received a *.lic license file: 

1. Click the Start button > Programs > Schlumberger > Schlumberger Licensing 201x > 
Schlumberger Licensing. 

2. Click Add license folder and browse to the *.lic file folder. 
3. Choose the folder and validate by clicking OK. 
4. Click Start to start the license service. 

 

Note: A window might open informing you that the changes are immediately applied, and that the 
setting is written in the operating system registry: click OK to continue. 

 

https://technet.microsoft.com/en-us/library/cc512612.aspx
https://technet.microsoft.com/en-us/library/dn551363.aspx#BKMK_SMBEncryption
http://support.software.slb.com/Pages/Overview.aspx
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5. Click OK to save your license configuration. 
 

If you work in a company using the license server, you must specify the license server 
address in the License server field. 

 

 

If you work in a company using the license server: 

1. Specify the license server address in the license server field. 
2. Use the Schlumberger licensing tool and map the license file. 
3. Ensure that the Schlumberger licensing tool is running. 

 

If you work using a license file: 

1. Specify license server address as @localhost in the License server field.  
2. Ensure that the Schlumberger licensing tool is running. 

License borrowing is useful to work off-line  without a proper connectivity or no connectivity to 
the license server, neither license file nor possibility to get one. 

 

Important: Ask for the borrowing feature when you order the license. 
 

You can perform the license borrowing with Python scripts. 

In Techlog: 

1. Click the   Menu > Licensing > One click borrowing. 

The script automatically borrows for 30 days. 

2. Launch Techlog with no connection to the license server to ensure that the borrowing 
was successful. If the borrowing fails, run again the script. 

In Techlog: 

1. Click the Utility tab > Python explorer > Techlog > Tools > Check borrowing to open 
the script. 

2. Run the script (use the F7 keyboard shortcut key) to prepare FlexLM for the borrowing. 
3. Close Techlog and reopen any Techlog version using the same daemon for which you 

want to borrow. 
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4. Launch Techlog with no connection to the license server to ensure the borrowing was 
successful. If the borrowing fails, run the clear borrowing.reg script to clear the registry 
entries (this script is located in the Techlog install and tools folders), and then repeat 
steps 1-3. 

 

Warning: Techlog license borrowing entries are deleted while running the clear borrowing script. If a 
feature cannot be returned due to a network or server issue, a window opens. You can choose 
the following options: 

 Continue: the borrowing process continues. 

 Force: the registry is cleaned up to consider that there are no more borrowed features. The 

features remain considered as borrowed on the server side. We recommend that you do not use 

this option. 

 Cancel: the borrowing process is canceled. 
 

From Techlog: 

1. Go to   Menu  > Licensing > FlexNet publisher to open the FlexNet tool. 
2. Click the Borrowing tab to set up the borrowed licenses. 

 
 

3. Set the Vendor Name field to slbfd to avoid any conflict with other software and 
indicate that the borrowing is done from the slbfd daemon. 

4. Set the Return Date and Return Time fields for the license. The return date must be 
within 30 days. 

5. Click Don't Borrow Anymore Today to avoid compatibility with other software using the 
same daemon but not supporting borrowing. 

6. Click Set Borrow Expiration. 
7. Close Techlog. 
8. Reopen all the Techlog versions using the same daemon for which the borrowing must 

be done with an existing or new project and enable all the modules you want to use from 
the Module Manager window. 

9. Close Techlog. 
10. Launch Techlog with no connection to the license server to ensure the borrowing was 

successful. 
11. If the borrowing failed, run the clear borrowing.reg script to clear the registry entries 

(this script is located in the Techlog install and tools folders), and repeat the previous 
steps. 

 

Warning: Techlog license borrowing entries are deleted while running the clear borrowing script. The 
features remain considered as borrowed on the server side. We recommend that you do not use 
this option. 
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The following section explains how to get Codemeter Dongle license working with Techlog 
2017 versions. 

 

 

The MAC address license server upgrade to Codemeter Dongle license must be explicitly 
requested to your Business Manager or Account Manager. 
Business and Account Managers can refer to the Procedure for use of Codemeter Dongles 
for Techlog document. 

 

The following steps are extracted from the Schlumberger Licensing User Guide available 
from Support Portal. In order to use dongle-based licenses, you must install the 
CodeMeterRuntime application. It is available on the software DVD in the same directory 
than the SLB Licensing installer or can be downloaded from the WIBU systems website. The 
minimum required version for Windows is 4.50c. 
 
1. Download the correct runtime version for your operating system from the WIBU systems 

website. 
2. Once downloaded, double click CodeMeterRuntimeXX.exe. 
3. When the installation wizard opens, follow the instructions clicking Next on each window 

to proceed. 
4. Install the runtime and when installation is completed click Finish. 

1. If you are using dongle-based licensing, insert the dongle into the USB port of your 
computer. 

2. Run the Schlumberger License Server configuration tool from Windows start menu: 
Start > All Programs > Schlumberger > Schlumberger Licensing > Schlumberger 
Licensing. 

3. Click Add License File and browse to the directory where you saved the license file. In 
the configuration tool, your license file has been added to the list of license files.  

4. Select Start Automatically with Windows for the license to be automatically available 
every time you restart your computer. 

5. Click Start to launch the license service. 
6. Click OK to apply the changes. 

The license server is set to @localhost. This is the address used by the application 
when attempting to find licenses on your local computer. You do not need to make 
changes as long as you only have a local license server. 
 
Click Status to display the licenses available and to check any potential issue with the 
license features. 
In case of issue, click Diagnostics to obtain more information on the license file(s) and 
the license server and to enable the access to the FlexNet debug log file. 
The Troubleshooting appendix describes the known issues and workarounds. If you 
cannot solve the issue and contact Schlumberger support, please always provide the 
contents of the diagnostics. 

  

http://support.software.slb.com/Pages/Overview.aspx
http://www.wibu.com/download_user.php
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To connect to a license server, Schlumberger applications require the server address. 
The address is in portnumber@machine.domain or portnumber@IP_address. For example, 
if the server is named server1 and using port number 27000, the address is 27000@server1. 
If you do not know the license server address, contact your system administrator. 

 

Note: If the license server has been configured with a port number within the default range of 
27000–27009 the port number can be dropped. In this case, @server1 will also be a 
valid address. 

 

1. In the Schlumberger license window, enter the server details in the Manage Remote 
Servers panel. 

2. Click Add license server to update the environment variable. 

To remove the license server details, select the entry in the list and click Remove license 
server. 
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Moving to a new version of Techlog will require upgrading the format of the project.  Once you upgraded to a new version of 
Techlog format, you cannot open the projects in the previous Techlog versions. 

 

Important: Projects created using a version earlier than Techlog 2014 are not supported anymore. 

In Techlog, click   Menu  > Project > Open project to display the list of Techlog project files, then 
select an Outdated project > Open. You are requested to upgrade the project.   

 If you select OK: the project will be automatically upgraded. The project will then be opened in 

the current version of Techlog. It will be impossible to open it in a previous version of Techlog 

and there will be no backup folder.   

 

Note: The automatic upgrade locks the project during the process: it is not possible to work on it. 
 

  If you select Cancel: the project will not be upgraded for the current version of Techlog. The 

project can be opened in a previous version of Techlog. 
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A Studio server needs to be accessed from Techlog. Please refer to the Studio installation 
Guide 2017 for more information on how to install Studio environment (Studio server and 
Studio database). 

 

Note: With Techlog 2017.2, Studio and Techlog do not support locale other than English. Installing a 
different locale for the server, database or Techlog will lead to unexpected behaviors and is not 
supported. 

A Studio server list can be defined in the CollaborationConfiguration.xml configuration file. 
The template of the file is located at path: 

[TechlogInstallationFolder]\Collaboration\CollaborationConfi

guration.xml 

The file can be set under User or Company folders by creating a Collaboration folder. The 
path to the file must be as follows:  

[YourUserFolder]\Collaboration\CollaborationConfiguration.xml 

[YourCompanyFolder]\Collaboration\CollaborationConfiguration.xml 

 

If the setting in the configuration file is available in both User and Company folders, the one 
in the User folder prevails. 

The configuration file can be edited to specify the Studio servers list. 

1. Open the configuration file in a text editor. 

2. Find and update the lines below (in black).  

 

3. Restart Techlog. 
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Studio can be specified as preferred collaboration environment in 
the CollaborationConfiguration.xml configuration file. The template of the 
file is available in the path: 

[TechlogInstallationFolder]\Collaboration\CollaborationConfi

guration.xml 

Edit the configuration file to specify Studio as preferred collaboration environment: 

1. Open the configuration file in a text editor. 
2. Find the line below. 

“Studio” is an option for Studio. 

<CollaborationSystem Studio="true" 

3. Specify the following options for each system: 

Active – “true” or “1” 

Inactive – “false” or “0” 

4. To reflect the change, restart Techlog. 

 

Note: The Synchronization tool is still available. It can be set up as preferred collaboration system using 
the “SyncTool” option in the configuration file. 

If the Techlog project has been connected to a Synchronization tool before, this connection overrides 
the configuration file settings until the project is unlinked from the current repository.  

For XML repository update, refer to Synchronization Tool deployment guide available in Techlog 
DVD. 
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To ensure that the daemon works properly on the server, run slbsls.exe -v in a 
Command Prompt. The version used for the daemon should be printed. If an error occurs, 
try with an older version of the daemon (provided in the package). 

 

You might receive the following FlexNet error message when you open Techlog: 

Error Code: Cannot borrow that long 

This error message means that you attempted to borrow a license for more than 30 days and 
Techlog cannot run. You need to re-borrow the license with an earlier return date. To do so, 
refer to the procedure described in the FlexNet Publisher section. 

 

You might receive the following error message: 

Error Code: Bad encryption code 

This error message is displayed when a computer time change occurred and some files have 
a future date. The licensing library detects the future date files and then prevents the 
opening. You can check and search for future date files in the computer (on C: & D: drives), 
from the current date to a much extended one, including hidden files and sub-folders to your 
search. 

To fix the issue, you must re-image the computer. 
 

 
 

This might be due to a missing network device. Ensure that the Wi-Fi card (wireless) is 
switched on. If you use a laptop, plug in the power adaptor. Also try to enable all connections 
in network connections under the Control Panel. 

 

Connection error_ network connect to THIS_HOST failed. 

a. License file configuration: 

THIS_HOST is a default host name in license file. 

It does not occur if you set the license to use it on a standalone workstation but it might occur 
if the computer calls its name as THIS_HOST. 

To avoid this issue, enter the correct host name in the license file. 

======================================================== 

SERVER this_host 0015c53766c6 1700 

VENDOR slbsls 

Modify the host name to reflect the workstation name and change the port number if it is 
already used by another application as described below: 

SERVER SITTIDET-OFTK 0015c53766c6 1701 

VENDOR slbsls 

======================================================== 

You can find the host name from Start > Control Panel > System and Security > System. 
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Modify the system environment SLBSLS_LICENSE_FILE (or LM_LICENSE_FILE) to include 
port@host_name or port@ip_address as in the following example port@host_name. 

  

 

b. Network configuration: 

If a dynamic IP address is used with the DNS service, the use of port@hostname should not 
create an issue. 

If a static IP address is used without the DNS service, the host name and IP address for all 
the client-servers, you must configure the workstation by modifying the host file in: 

C:\WINDOWS\system32\drivers\etc\ 

 

In this case, you can see 17010@johndoe.eur.slb.com or 17010@163.187.15.152.  
 

Contact your system administrator to disable the firewall or put an exception on Windows 
firewall. 

 

If you receive the following error while running the One click borrowing script, run the script 
again. This is a FlexLM issue not related to Techlog. 

lmborrow: Error, borrowed license doesn't match any known server 

license. (-128,595) 
 

  

mailto:17010@johndoe.eur.slb.com
mailto:17010@163.187.15.152
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If you use Techlog, this error means that the license that you are attempting to use for 
borrowing does not support the borrowing. 

If you use Petrel, you must change the Vendor Name from All to slbfd in the Borrowing tab 
of FlexNet Publisher. 

 

Some anti-virus software might crash Techlog at opening. If you experience this issue, add 
Techlog to the anti-virus exclusion list and reopen Techlog. Multi license quorum’s settings 
might lead to a potential crash at Techlog opening. If a crash at Techlog opening occurs, the 
workaround is to reduce the number of quorum and reopen Techlog. 

 

If the connection to the file system is interrupted on file import, depending upon the file 
format Techlog will handle the issue correctly by retrying and notifying the user of the 
issue. Some import type this failure may cause a Techlog failure causing the application 
to close. 
If the connection is lost during a file export the state of the file may not be valid.  Need to 
verify test cases and document issue. 

 


